How to get CUPS to work (newbie)

stan stanb at
Sat Aug 30 23:01:36 PDT 2003

On Sat, Aug 30, 2003 at 11:32:50PM -0400, Todd Stephens wrote:
> I have CUPS installed on my 4.8 system.  I cannot seem to configure it, 
> though.  I have tried the web interface at localhost:631, but it seems 
> that the cupsd.conf file was not created.  Well, then I tried to create 
> this using the print server configuration in KDE and I keep getting 
> permission denied errors when I try to write the cupsd.conf file 
> (running this as root, btw).
> Basically I am looking for a tutorial somewhere to get CUPS up and 
> running on FreeBSD.  Actually, I do have it running, I just can't 
> configure it or add any printers.  Not much use without printers :)
> I checked on, and the CUPS page there doesn't cover the 
> configuration of the server itself it seems.
> Any help is greatly appreciated.
Just from memory, I think tht a /usr/local/etc/cups/cupsd.conf file is
installed by the port. You need to read through it, and set up the access
control to allow you to configure prnters via the web interface. There are
exmaples in there. If I recall corectly, the default does not allow
configuring, even from the local achine.

Hope that helps.

"They that would give up essential liberty for temporary safety deserve
neither liberty nor safety."
						-- Benjamin Franklin

More information about the freebsd-questions mailing list