Filesystem problem

Kevin Bockman neoninternet at
Sat Aug 30 19:11:16 PDT 2003

Hi. I have been experencing some filesystem problems
for the last month or so. I was running 4.8-STABLE and
updated to 5.1-RELEASE-p2.  While I was running 4.8
and I tried to run a command that required hard disk
activity, the process would 'hang' and I would no
longer be able to ssh or telnet in.  I would get stuck
after typing in my login.

Running 5.1 is a different story.  I did a clean
install of 5.1-RELEASE and cvsup'd to -p2.  Every time
I do this, it's great for a day or so then it acts up.
 Before after it started, even if I rebooted it would
immediately start up.  On 5.1, it is only hanging for
that process and everything else is fine.  I can still
login, webserver responds, etc.

Here is a little info:

FreeBSD 5.1-RELEASE-p2 FreeBSD
5.1-RELEASE-p2 #0: Sat Aug 23 20:12:41 PDT 2003    
kevin at

CPU: AMD Athlon(tm) XP 2600+ (2086.51-MHz 686-class
real memory  = 1073676288 (1023 MB)
ad0: 117246MB <Maxtor 6Y120P0> [238216/16/63] at
ata0-master UDMA133

root   1173  0.0  0.1  1436  916  p3  D+    6:38PM  
0:00.00 man vmstat
root    784  0.0  0.1   752  636  d0  D     4:34PM  
0:00.02 make all DIRPRFX=i386/libi386/
root    847  0.0  0.0   312  212  d0  D     4:34PM  
0:00.00  (cc)
root    848  0.0  0.3  4104 3488  d0  D     4:34PM  
0:00.01  (cc1)
root    849  0.0  0.1   928  668  d0  D     4:34PM  
0:00.00 /usr/bin/as -o comconsole.o -

last pid:  1252;  load averages:  0.00,  0.00,  0.00  
                                up 0+02:37:22 
64 processes:  1 running, 63 sleeping
CPU states:  0.0% user,  0.0% nice,  0.0% system, 
0.0% interrupt,  100% idle
Mem: 34M Active, 23M Inact, 38M Wired, 204K Cache, 22M
Buf, 906M Free
Swap: 2048M Total, 2048M Free

devel# vmstat
 procs      memory      page                    disks 
   faults      cpu
 r b w     avm    fre  flt  re  pi  po  fr  sr ad0 da0
  in   sy  cs us sy id
 1 7 0  144612 928056   16   0   0   0   9   0   0   0
 331    0 254  0  0 100

Anyone have any suggestions?  I can not control-C out
of 'man vmstat'.  While doing 'make' in
/usr/src/sys/boot it was hanging on as, when I
restarted it, it got to i386/libi386 and will not do
anything else.  I'm running that through serial
console, it let me ^C out of that.  I tried going into
single user mode and running umount, now it just sits
there and I can't ^C.  I have no ideas, this was all
working yesterday!! :-)

Any ideas on what else to check or other helpful hints
would help bunches.



Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software

More information about the freebsd-questions mailing list