freebsd boot and fsck problem

Jennifer jennifer at
Tue Aug 26 20:47:37 PDT 2003

Dear FreeBSD people

I started to learn and used FreeBSD from last year. And I found FreeBSD is
really very powerful and lovely. But I am also a little scared of it, for
then it has problem, I just do not know how to fix it.

Here I came up a big emergent problem  this morning, and I wish you can give
me your precious advice and help.

 I have been using   a script for a couple of months to do full
 backup once a week. This is a small scripts to copy whole IDE
HDD (of freeBSD)
 to another HDD. Please have a look at the attached script
 It worked very fine till yesterday.

 Last night, As usual,I started ./ to backup my FreeBSD4.3
 (Disk1) on another HDD(Disk2). Disk2 has been used successfully as backup
 for more than 10 times with same procedure of ./
 So it seemed the start up going smoothly, then I left the server room.
 This morning, when I came to check the server and backup. (which was
 supposed to have finished). And I surprised to find all those horrible
 messages on the console screen:

 ***start to quote error message
 ad0s2e: had error reading fsbn 97103692 of 3473456-3473467(ad0s2 bn
 97103692; cn 6044 fn 108 sn 28) status=59 error=40
 cannot read: BLK 3473456
 **end of error message quote
 So I had to force to suspend the backup process by pressing Ctrl+Z.
 Then I tried to reboot Disk1. I had problem during the booting process.

 **start to quote error message
 chflags: not found
 chown: not found
 cd: can't cd to /var/run
 cd: can't cd to /var/spool/lock
 /etc/rc: cann't create /var/run/dmesg.boot directory nonexistent
 cd: can't cd to /var/run
 /etc/rc: cannot ceate
 /var/run/clean_var:dirctory nonexitent.
 Enter full path of shell or return for /bin/sh
 **end of error message quote
 Then I just press Enter and came to the single boot mode. I typed the
 following command to try to munually fsck the problem partition.
 #fsck /dev/ad0s2e
 The console then showed the following message.
 **Last mounted on /www
 **Phase 1 -check block & size
 cannot read: BLK 19596336
 continue [y/n]

 Looks like the manual fsck doesn't working here.
 Then I tried my luck to boot Disk2.Unfortunately, it showed the same errors
 as Disk2 during booting.

 Your  advice will be highly appreciated.


 P.S. The attached is my,which had worked fine for the previous
 backup processes except yesterday. So I do not think anything wrong with
the itself. There must be something wrong with my yesterday's
 backup process, though I can not find out what it is.

-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/octet-stream
Size: 1074 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list