after running the installer on a PowerMac G5 no root filesystem found

Andreas Tobler andreast-list at
Thu Nov 15 20:14:01 UTC 2018

On 15.11.18 21:05, Michael Tuexen wrote:
>> On 14. Nov 2018, at 18:02, Justin Hibbits <chmeeedalf at> wrote:
>> On Wed, 14 Nov 2018 11:52:45 -0500
>> Dennis Clarke <dclarke at> wrote:
>>> <snip>
>>>>>> At first boot I get a load of text and then a strange prompt that
>>>>>> seems to be asking where is the root filesystem? It also lists
>>>>>> all the various filesystems found. I tried to enter
>>>>>> ufs:/dev/adas2 and similar things but this gets me nothing but an
>>>>>> unrecognized filesystem message.
>>>>>> So .. something obvious?
>>>>> Can you try setting the variable kern.smp.disabled to 1 at the
>>>>> loader prompt?
>>>>> If that helps, you can add
>>>>> kern.smp.disabled=1
>>>>> to /boot/leader.conf
>>>> I meant /boot/loader.conf.
>>> To do that at all I would need to be able to get to the root
>>> filesystem.
>> You can do it at the loader.
>> set kern.smp.disabled=1
>> boot
>>>>> I had all sorts of problems until I disabled SMP on my G5
>>>>> PowerMacs. Without SMP they are running very stable.
>>> So FreeBSD can not run on ye old IBM PPC970 units with multiple cores
>>> or multiple sockets?  That sounds like a critical bug.
>> It could until recently, due to my fault.  I can revert the change that
>> caused it, but haven't yet, because I don't understand why it's causing
>> the problem.  And I'm pretty confident it's not causing the mountroot
>> issue (though, I was pretty confident it wouldn't cause any problem
>> anyway, but that turned out to be false confidence).
> OK, I did some testing. Reverting r334498 and not disabling smp results
> in a usable, stable system. However, there are two things I observed that
> are not working as good as with disabling smp:
> 1. After a while the fans get louder. Running sysctl -a dev.fcu.0
>     gets them down again. After a while they will start to get
>     louder again.
>     When SMP is disabled, this is not an issue.

pmac_therm gets stuck, we already had that, r329080 tried to fix this.
It worked a while but now things are back to worse.

> 2. When shutting down the system,
>     Waiting (max 60 seconds) for system thread `bufdaemon' to stop...
>     Waiting (max 60 seconds) for system thread `bufspacedaemon-1' to stop...
>     Waiting (max 60 seconds) for system thread `bufspacedaemon-0' to stop...
>     times out.
>     This is also not an issue when SMP is disabled.
> So there are some issue with SMP even when reverting r334498.

I second the two points above, iow I see the same on different SMP G5 
running 64-bit. For me both are related.


More information about the freebsd-ppc mailing list