after running the installer on a PowerMac G5 no root filesystem found

Mark Millard marklmi at
Thu Nov 15 20:47:58 UTC 2018

On 2018-Nov-15, at 12:13, Andreas Tobler <andreast-list at> wrote:

> On 15.11.18 21:05, Michael Tuexen wrote:
>>> . . .
>> OK, I did some testing. Reverting r334498 and not disabling smp results
>> in a usable, stable system. However, there are two things I observed that
>> are not working as good as with disabling smp:
>> 1. After a while the fans get louder. Running sysctl -a dev.fcu.0
>>    gets them down again. After a while they will start to get
>>    louder again.
>>    When SMP is disabled, this is not an issue.
> pmac_therm gets stuck, we already had that, r329080 tried to fix this.
> It worked a while but now things are back to worse.

In my context somethings things go for weeks without
this happening. I also have more trouble with such from
debug kernel builds than from non-debug ones. I normally
run non-debug kernels unless I'm trying to track down
some issue.

For non-debug kernels rebooting (shutdown -r now) does
seem to initially clear the condition.

This has been a fairly long term issue.

>> 2. When shutting down the system,
>>    Waiting (max 60 seconds) for system thread `bufdaemon' to stop...
>>    Waiting (max 60 seconds) for system thread `bufspacedaemon-1' to stop...
>>    Waiting (max 60 seconds) for system thread `bufspacedaemon-0' to stop...
>>    times out.
>>    This is also not an issue when SMP is disabled.
>> So there are some issue with SMP even when reverting r334498.
> I second the two points above, iow I see the same on different SMP G5 running 64-bit. For me both are related.

I've seen this and, as I remember, it has been under debug kernels
instead of non-debug ones. Since I normally run non-debug kernels,
I normally do not see this.

The powerpc's involved are still based on -r339076. The prior
context  with much use was long before that, predating -r334498
as well. I do not remember seeing this before the jump to
-r339076 .

So I expect this is somewhat new.

I can not comment much on having smp disabled. The only time
that I've had such was the jump to -r339076 until I identified
reverting -r334498 as how to get back to a nearly
historically-normal context.

Mark Millard
marklmi at
( went
away in early 2018-Mar)

More information about the freebsd-ppc mailing list