Portmaster error

Adam Vande More amvandemore at gmail.com
Wed Sep 27 15:41:50 UTC 2017

On Wed, Sep 27, 2017 at 10:22 AM, Paul Schmehl <pschmehl_lists at tx.rr.com>

> I'm running a 10.3-RELEASE instance. I ran portmaster -ad in screen
> yesterday to get all the ports up to date. Today I ran it again, to make
> sure everything was updated.
> When I did, I got this error:
> portmaster -ad
> ===>>> Gathering distinfo list for installed ports
> ===>>> Starting check of installed ports for available updates
> make: "/usr/ports/Mk/bsd.port.mk" line 1462: Cannot open
> /usr/ports/Mk/Uses/execinfo.mk
> make: Fatal errors encountered -- cannot continue
> ===>>> All ports are up to date
> Sure enough, execinfo.mk is missing.
> I ran portsnap fetch and update to see if that would fix it. It did not.
> I didn't find anything about this on the web or in /usr/ports/UDPATING. Is
> this something new? Is there something I can do to fix it other than wait?
A portsnap extract might workaround it.


More information about the freebsd-ports mailing list