Portmaster error

Paul Schmehl pschmehl_lists at tx.rr.com
Wed Sep 27 15:24:02 UTC 2017

I'm running a 10.3-RELEASE instance. I ran portmaster -ad in screen 
yesterday to get all the ports up to date. Today I ran it again, to make 
sure everything was updated.

When I did, I got this error:

 portmaster -ad
===>>> Gathering distinfo list for installed ports

===>>> Starting check of installed ports for available updates
make: "/usr/ports/Mk/bsd.port.mk" line 1462: Cannot open 
make: Fatal errors encountered -- cannot continue
===>>> All ports are up to date

Sure enough, execinfo.mk is missing.

I ran portsnap fetch and update to see if that would fix it. It did not.

I didn't find anything about this on the web or in /usr/ports/UDPATING. Is 
this something new? Is there something I can do to fix it other than wait?

Paul Schmehl, Retired
As if it wasn't already obvious, my opinions
are my own and not those of my employer.
"It is as useless to argue with those who have
renounced the use of reason as to administer
medication to the dead." Thomas Jefferson
"There are some ideas so wrong that only a very
intelligent person could believe in them." George Orwell

More information about the freebsd-ports mailing list