Install of pkg fuse-ntfs fails because of undefined symbol in pkg!?!

scratch65535 at scratch65535 at
Wed Feb 8 12:08:19 UTC 2017

[Default] On Wed, 8 Feb 2017 12:46:09 +0100, Franco Fichtner
<franco at> wrote:

>> On 8 Feb 2017, at 12:29 PM, <scratch65535 at> <scratch65535 at> wrote:
>> I just tried to install the fuse-nfts pkg under 10.2 on my
>> server-of-all-work.  But after requiring me to "upgrade" pkg, the
>> fuse-ntfs install failed, apparently because there's an undefined
>> symbol ("utimenstat") in pkg itself!
>> How do I extricate myself?
>The latest supported release is FreeBSD 10.3 and packages are therefore
>build against it.  It creates this soft breakage inside the fixed ABI,
>which quite a few people run into.
>There are two solutions:
>(a) Build the packages yourself on a FreeBSD 10.2.
>(b) Upgrade to FreeBSD 10.3 and do a "pkg upgrade -f" run.

Perhaps it's just that I've spent too much of my life doing
human-factors work, but if pkg doesn't want to do anything for me
once my version has passed its use-by date, it damned well
shouldn't do ANYTHING.  It should just tell me "nope, 10.2 is too
old, entirely toooooo olllllldddd.  No packages for you!"  

The one thing it should NEVER do is break its existing install!  

I agree with your urging, Franco, that the problem be solved in a
general and non-hostile way.

Now, how do I revert the pkg version? :-(

More information about the freebsd-ports mailing list