HTML5 videos crashes Firefox

Andrea Venturoli ml at
Tue Mar 29 16:20:25 UTC 2016

On Sun, 27 Mar 2016 10:12:07 -0700, Christoph Brinkhaus wrote:

> Hello Andrea,

Hello and thanks for your help.

> I have tried the first video I get from youtube without problems.
> May be you post an url where the crash occurs.

I can just go to and choose a random one; e.g.:

(Please forgive me for linking that crap, but you asked it :)

> The options I use are
> according to pkg info
> ALSA : on
> CANBERRA : off
> DBUS : on
> DEBUG : off
> DTRACE : off
> FFMPEG : on
> GCONF : off
> GIO : on
> GNOMEUI : off
> GTK2 : on
> GTK3 : off
> LIBPROXY : off
> PGO : off
> PROFILE : off
> TEST : off

I had:
>         ALSA           : off
>         BUNDLED_CAIRO  : on
>         CANBERRA       : off
>         DBUS           : on
>         DEBUG          : off
>         DTRACE         : on
>         FFMPEG         : on
>         GCONF          : off
>         GIO            : on
>         GNOMEUI        : off
>         GTK2           : off
>         GTK3           : on
>         INTEGER_SAMPLES: off
>         LIBPROXY       : off
>         OPTIMIZED_CFLAGS: on
>         PGO            : off
>         PROFILE        : off
>         PULSEAUDIO     : on
>         RUST           : on
>         TEST           : off

However, I tried your set of options (with RUST on and off, since you 
don't have it): things didn't change, still crashing.

 > The version is 45.0.1,1

45.0.1_3,1, here, but I also went through 45.0.1,1, which crashed in the 
same way.

> May be you try pkg_libchk from sysutils/bsdadminscripts
> if the libraries are in order.

I used sysutil/libchk, which should do more or less the same thing: 
there were some unresolved references in binaries which should not be 
related to FireFox: I solved that, but it's still crashing.
Any other thing to check?

> Do you have an i386 kernel?


> I am not sure if there might be a possible issue.

Any pointer on that?
*If* firefox is incompatible with i386 I might switch, but it's going to 
be a very long work; so I'd like to get some hint about this before I 
venture myself in such a trouble.

> When I have started using FreeBSD I thought amd64 is just for AMD processors.
> But amd64 is also ok for Intel.

I know the difference.
However this box's install predates amd64: I was using it more than 10 
years ago (5.x or 6.x possibly) and it's still there through several 
hardware and software upgrades.
Until now I haven't found any good reason to drop everything and 
reinstall from scratch...

 > This is likely the newest one. I am not completely up to date because
 > I mostly upgrade only when there are vulnerabilities.

So do I, but I've gone through every minor update since I'm experiencing 
these crashes.

  bye & Thanks

More information about the freebsd-ports mailing list