HTML5 videos crashes Firefox

Christoph Brinkhaus c.brinkhaus at
Sun Mar 27 17:11:47 UTC 2016

On Sun, Mar 27, 2016 at 06:06:01PM +0200, Andrea Venturoli wrote:
> Hello.
> Since a week or two my FireFox crashes as soon as an HTML5 video starts 
> playing. This can be sistematically reproduced, for example, by opening 
> YouTube and selecting a random video.
> Notice I'm not that intrested in such videos, I just hate it when I open 
> a page with one on it (possibly advertisement) and the 25 opened 
> windows/tabs suddenly die.
> Nothing is printed on the terminal apart from "Bus error (core dumped)".
> Obviously the core file is useless, but I tried recompiling FireFox with 
> debug symbols and that didn't make it any more readable (only some ?? in 
> the stack trace).
> "portupgrade -Rf firefox" was only a waste of time.
> I switched from GTK2 to GTK3 (which I think became the default in the 
> meanwhile), but the crashes weren't affected.
> I deleted my config and rebuilt with default options, only to get the 
> same behaviour.
> I read disabling ALSA might solve, but it didn't (besides, it was 
> enabled before the crashes started).
> I remembered in the past we had to load sem.ko, but it didn't help either.
Hello Andrea,

I have tried the first video I get from youtube without problems.
May be you post an url where the crash occurs. The options I use are
according to pkg info
ALSA           : on
CANBERRA       : off
DBUS           : on
DEBUG          : off
DTRACE         : off
FFMPEG         : on
GCONF          : off
GIO            : on
GNOMEUI        : off
GTK2           : on
GTK3           : off
LIBPROXY       : off
PGO            : off
PROFILE        : off
PULSEAUDIO     : off
TEST           : off
The version is 45.0.1,1
> So I'm just looking for any hint that could help me get on the right 
> track to debug this.
> TIA to anyone who will answer.
May be you try pkg_libchk from sysutils/bsdadminscripts
if the libraries are in order.
> Some info:
> > % uname -a
> > FreeBSD alamar.ventu 10.2-RELEASE-p14 FreeBSD 10.2-RELEASE-p14 #5 r297011: Fri Mar 18 10:48:43 CET 2016 root at alamar.ventu:/usr/obj/usr/src/sys/ALAMAR i386
Do you have an i386 kernel?
I am not sure if there might be a possible issue.

When I have started using FreeBSD I thought amd64 is just for AMD processors.
But amd64 is also ok for Intel.

> > % ident /usr/ports/www/firefox/Makefile
> > /usr/ports/www/firefox/Makefile:
> > $FreeBSD: head/www/firefox/Makefile 411909 2016-03-25 23:30:06Z jbeich $
This is likely the newest one. I am not completely up to date because I mostly
upgrade only when there are vulnerabilities.
>   bye
> 	av.
Kind regards,

More information about the freebsd-ports mailing list