Call for testers -- CONF_FILES variable

Chris Rees crees at
Thu Jun 30 07:22:44 UTC 2011

On 30 June 2011 01:35, Jeremy Messenger <mezz.freebsd at> wrote:
> On Wed, Jun 29, 2011 at 3:24 PM, Chris Rees <crees at> wrote:
>> Dear all,
>> I've rewritten the CONF_FILES handling after talking to bapt@, and
>> I've done away with the
>> colon-separated tuples -- they're overcomplicated.
>> The result is something like MAN and PORTDOCS (indeed most of the code
>> is stolen from PORTDOCS).
>> This means that shell globs, filenames and directories are specified
>> in CONF_FILES, but the sample file is installed in the Makefile as
>> .pkgconf.
> I like the rest, but I do not like the name of .pkgconf. I think, the
> 'pkgconf' is best define for something related with FreeBSD rather
> than third-party product. The .sample or .default is best name and
> less confuse for the users, because the word said it all what it is.

Thanks for the feedback.

I'm afraid any problems with the .pkgconf sample will have to be
discussed with the pkgng team and bapt@ -- wasn't my choice either.


More information about the freebsd-ports mailing list