Call for testers -- CONF_FILES variable

Julien Laffaye jlaffaye at
Thu Jun 30 11:48:02 UTC 2011

On 06/30/2011 08:22, Chris Rees wrote:
>> I like the rest, but I do not like the name of .pkgconf. I think, the
>> 'pkgconf' is best define for something related with FreeBSD rather
>> than third-party product. The .sample or .default is best name and
>> less confuse for the users, because the word said it all what it is.
> Thanks for the feedback.
> I'm afraid any problems with the .pkgconf sample will have to be
> discussed with the pkgng team and bapt@ -- wasn't my choice either.
> Chris

Yes, right now, pkgng uses the .pkgconf suffix to know that it is a
configuration file. But now, we have a new format for the package
manifest so _maybe_ (it has to be discussed with bapt) we can add an
attribute to a file entry saying "I am a sample of a conf file". The
hardest part for that would be to detect in the ports tree if we are
using pkgng or the legacy pkg_install, and, depending on that, to
generate the appropriate entry in the manifest / plist.

More information about the freebsd-ports mailing list