Call for testers -- CONF_FILES variable

Jeremy Messenger mezz.freebsd at
Thu Jun 30 01:05:03 UTC 2011

On Wed, Jun 29, 2011 at 3:24 PM, Chris Rees <crees at> wrote:
> Dear all,
> I've rewritten the CONF_FILES handling after talking to bapt@, and
> I've done away with the
> colon-separated tuples -- they're overcomplicated.
> The result is something like MAN and PORTDOCS (indeed most of the code
> is stolen from PORTDOCS).
> This means that shell globs, filenames and directories are specified
> in CONF_FILES, but the sample file is installed in the Makefile as
> .pkgconf.

I like the rest, but I do not like the name of .pkgconf. I think, the
'pkgconf' is best define for something related with FreeBSD rather
than third-party product. The .sample or .default is best name and
less confuse for the users, because the word said it all what it is.


> Examples for MailScanner [1] show how it can replace huge trees of
> config files, and for portscout [2] shows how it is used for just one
> file.
> Look at how much has been removed from the MailScanner plist and
> pkg-* files -- there are three screens of unused functions
> that could also be chopped out now too!
> I'm asking people to (if they want) try out the new variable, and let
> me know what they like and don't like about it.
> Since bapt@ is sort of sponsoring this and isn't back for ~ two weeks
> it won't make it in before then at least, but some testing and
> feedback would be fantastic!
> Chris
> [1]
> [2]
> P.S. Before people complain about the pkgconf suffix, that is for
> compatibility with pkgng, and no, .sample files are not going to be
> supported -- they'll need to be installed as .pkgconf. Sorry.

mezz.freebsd at - mezz at
FreeBSD GNOME Team - gnome at

More information about the freebsd-ports mailing list