mailman upgrade broke "group mismatch"

Jeremy Messenger mezz7 at
Wed Jun 7 19:14:46 UTC 2006

On Tue, 06 Jun 2006 21:25:54 -0500, Xin LI <delphij at> wrote:

> Hi, Lee,
> 在 2006-06-06二的 22:01 -0400,Lee Dilkie写道:
>> I've tried changing the group on the /usr/local/mailman tree to
>> "mailnull"
>> I've tried setting MM_GROUPNAME=mailnull and MM_GROUPID=26 (mailnull's
>> group ID) in /etc/make.conf and running portupgrade -f mailman. In
>> order for "configure" to work I have to "chgrp -R
>> mailnull /usr/local/mailman" first. But that doesn't work in the end
>> either. Actually, the web interface works but posts to lists don't do
>> anything, no bounce either.
>> I've tried mv-ing /usr/local/mailman to another directory and
>> re-installing mailman into a clean directory, copying over those files
>> I think are important from the old dir (all my lists and stuff), and
>> still it doesn't work. BTW, the default mailman from ports does *not*
>> use group "mailnull", it uses "mailman".
>> Just what do I have to do to get my lists back up and working again?
> Have you tried to have a "make config" in ports/mail/mailman and choose
> postfix, then deinstall and reinstall the port?
> BTW.  Having the configuration in /etc/make.conf is not generally
> encouraged.  If you use portupgrade(1) then it would be better to
> use /usr/local/etc/pkgtools.conf instead.

I disagree, the make.conf is global and will work by any tools. Therefore,  
pkgtools.conf is not generally encouraged.


> Cheers,

mezz7 at  -  mezz at
FreeBSD GNOME Team  -  gnome at

More information about the freebsd-ports mailing list