mailman upgrade broke "group mismatch"

Lee Dilkie Lee at
Wed Jun 7 14:31:10 UTC 2006

Xin LI wrote:
> Hi, Lee,
> 在 2006-06-06二的 22:01 -0400,Lee Dilkie写道:
>> I've tried changing the group on the /usr/local/mailman tree to
>> "mailnull"
>> ...
>> Just what do I have to do to get my lists back up and working again?
> Have you tried to have a "make config" in ports/mail/mailman and choose
> postfix, then deinstall and reinstall the port?
Yes, But I choose "sendmail" as that is my MTA.
> BTW.  Having the configuration in /etc/make.conf is not generally
> encouraged.  If you use portupgrade(1) then it would be better to
> use /usr/local/etc/pkgtools.conf instead.
Understood, but I use a .if ${.CURDIR} == "/usr/ports/mail/mailman" to 
limit the variables' scope. I find the syntax in pkgtools.conf confusing.

I did get it to work but I'll confess that I'm not sure exactly what 
magic did the trick.

One of the issues that I discovered was that 
/usr/local/etc/rc.d/ start doesn't appear to actually start 
the qrunners and that mailmanctl start does. Oh... I see, they've added 
a "mailman_enable" to rc.conf.. Boy, do I feel stupid. Don't know if the 
directory permissions problem was related or not. I guess I'll find out 
on the next portupgrade ;)


More information about the freebsd-ports mailing list