mailman upgrade broke "group mismatch"

Xin LI delphij at
Wed Jun 7 02:36:55 UTC 2006

Hi, Lee,

在 2006-06-06二的 22:01 -0400,Lee Dilkie写道:
> I've tried changing the group on the /usr/local/mailman tree to
> "mailnull"
> I've tried setting MM_GROUPNAME=mailnull and MM_GROUPID=26 (mailnull's
> group ID) in /etc/make.conf and running portupgrade -f mailman. In
> order for "configure" to work I have to "chgrp -R
> mailnull /usr/local/mailman" first. But that doesn't work in the end
> either. Actually, the web interface works but posts to lists don't do
> anything, no bounce either.
> I've tried mv-ing /usr/local/mailman to another directory and
> re-installing mailman into a clean directory, copying over those files
> I think are important from the old dir (all my lists and stuff), and
> still it doesn't work. BTW, the default mailman from ports does *not*
> use group "mailnull", it uses "mailman".
> Just what do I have to do to get my lists back up and working again?

Have you tried to have a "make config" in ports/mail/mailman and choose
postfix, then deinstall and reinstall the port?

BTW.  Having the configuration in /etc/make.conf is not generally
encouraged.  If you use portupgrade(1) then it would be better to
use /usr/local/etc/pkgtools.conf instead.

Xin LI <delphij delphij net>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: =?UTF-8?Q?=E8=BF=99=E6=98=AF=E4=BF=A1=E4=BB=B6=E7=9A=84=E6=95=B0?=
Url :

More information about the freebsd-ports mailing list