Installing Ports

Ion-Mihai Tetcu itetcu at
Wed Mar 23 12:15:55 PST 2005

On Wed, 23 Mar 2005 14:01:37 -0600
"Ryan Lessl" <rmlessl at> wrote:

> Hello, first of all I want to say that I am enjoying using
> FreeBSD 4.11 Release.  I am a total novice at this but have
> been learning a lot and am glad I finally canned Windows.  I
> got very tired of it and have tried a very small Linux
> distribution and now FreeBSD and they both worked/are
> working better than Windows did on my machine (I've only got
> FreeBSD installed currently).
> Can you help me?
> Okay, so I tried to install the AIM program by using the
> command "make install" in the /usr/ports/net/aim/ directory,
> and it did a bunch of stuff that I'm guessing is what you
> call "compiling" downloaded stuff and wrote new folders
> and files, and said it was registering the installation, and
> told me it was all through when it was all through.  But I
> can't figure out how to run the program.  I found the new
> folders and files it created, including an "executable file"
> called "aim" in a new "aim" folder, but I couldn't run it. 
> I tried clicking on it, running it from a terminal, and
> running it from the KDE "Run Command" box, but none of that
> worked.  Then I tried the "rehash" command like it suggested
> in the online manual, but that didn't change the situation. 

And the error was ?

> What do I need to do?  The installation html that it gives
> me has specific instructions for all OSs except FreeBSD,
> only an "other OSs" section, and I'm not real sure if what
> that tells me to do is actually what I need to do.

In the shell in which you did rehash, do a:
 ls -l `which aim`
and then
 `which aim`

If it doesn't run after the second command then send us the output of
the first.

Unregistered ;) FreeBSD "user"

More information about the freebsd-ports mailing list