Installing Ports

Fernan Aguero fernan at
Wed Mar 23 12:36:44 PST 2005

+----[ Ryan Lessl <rmlessl at> (23.Mar.2005 17:06):
| Hello, first of all I want to say that I am enjoying using
| FreeBSD 4.11 Release.  I am a total novice at this but have
| been learning a lot and am glad I finally canned Windows.  I
| got very tired of it and have tried a very small Linux
| distribution and now FreeBSD and they both worked/are
| working better than Windows did on my machine (I've only got
| FreeBSD installed currently).


welcome aboard

| Can you help me?

we'll try

| Okay, so I tried to install the AIM program by using the
| command "make install" in the /usr/ports/net/aim/ directory,
| and it did a bunch of stuff that I'm guessing is what you
| call "compiling" downloaded stuff and wrote new folders
| and files, and said it was registering the installation, and
| told me it was all through when it was all through.

Pretty close. aim is not distributed as source code
that you have to compile but as a pre-compiled binary.

The port, in this case, just fetched the distribution file,
extracted it, and installed everything in place. It did the
same, in this case, that a Windows Installer would have done.

| But I
| can't figure out how to run the program.  I found the new
| folders and files it created, including an "executable file"
| called "aim" in a new "aim" folder, but I couldn't run it. 

It doesn't create new folders ... it installs the aim
executable in /usr/X11R6/bin/ which should already be there
and populated with stuff from other ports or packagess.

Perhaps you refer to the files and folders that are in
/usr/ports/net/aim/work/*? If so, this is a temporary folder
created when the port extracted the contents of the
distribution file. It would get removed if you do a 'make

| I tried clicking on it, running it from a terminal, and
| running it from the KDE "Run Command" box, but none of that
| worked.  Then I tried the "rehash" command like it suggested
| in the online manual, but that didn't change the situation. 
| What do I need to do?  The installation html that it gives
| me has specific instructions for all OSs except FreeBSD,
| only an "other OSs" section, and I'm not real sure if what
| that tells me to do is actually what I need to do.
| Thanks,
| Ryan

After succesffully installing the application from the port
(as root), you should open a terminal (xterm, or konsole if
your're using KDE) as yourself (not root) and type 'rehash'
so that the directories in the PATH are re-read and then

BTW, I just happen to have installed aim yesterday and it
seems to be broken. I'm also using 4.11

Before I go on to some details, the best that you can do is
forget about aim (I tried it for other reasons) and use gaim
instead (net/gaim) it will let you use you aim account and
many others (MSN, yahoo) 

Good Luck!


PS: For anyone interested this is what I get when running it:

/usr/X11R6/libexec/aim: error while loading shared
libraries: cannot open shared object file: No
such file or directory

and it seems like this is not the only shared library missing:
[fernan at pi] ldd /usr/X11R6/libexec/aim
/usr/X11R6/libexec/aim: => /usr/lib/ (0x28068000) => /usr/lib/ (0x2819e000) => /usr/lib/ (0x281d4000) => /usr/lib/ (0x281d7000) => /lib/ (0x281fd000) => /usr/X11R6/lib/ (0x28200000) => /usr/X11R6/lib/ (0x28208000) => /usr/X11R6/lib/ (0x28218000) => not found => not found => not found => /lib/ (0x28314000) => /lib/ (0x28365000) => /usr/lib/ (0x28387000) => /lib/ (0x283c9000)
        /lib/ => /lib/ (0x28051000)

Maybe we should mark this port as BROKEN?

More information about the freebsd-ports mailing list