[Solved] Re: Gimp-2.2.2 wants freetype-2.1.7; but I already have ?!?!

spam maps spamrefuse at yahoo.com
Mon Jan 24 04:51:37 PST 2005

Rob wrote:
> I have:
>   gimp-2.2.2,1
>   freetype2-2.1.7_4
> When I start gimp, I get a dialog that says:
>    FreeType too old!
>    The GIMP requires FreeType version 2.1.7 or
>    later.
>    Installed FreeType version is 2.1.4.
>    Somehow you or your software packager managed
>    to install The GIMP with an older FreeType
>    version.
>    Please upgrade to FreeType version 2.1.7 or

Some time ago, I have installed openoffice 1.1.4
from package. After installation, I discovered:

$ ldd /usr/local/[...]/soffice.bin | grep "not found"
        libvcl645fi.so => not found (0x0)
        libsvl645fi.so => not found (0x0)
        libsvt645fi.so => not found (0x0)
        libutl645fi.so => not found (0x0)
        libtl645fi.so => not found (0x0)
        libcomphelp3gcc3.so => not found (0x0)
        libucbhelper2gcc3.so => not found (0x0)
        libvos3gcc3.so => not found (0x0)
        libcppuhelpergcc3.so.3 => not found (0x0)
        libcppu.so.3 => not found (0x0)
        libsal.so.3 => not found (0x0)
        libtk645fi.so => not found (0x0)
        libstlport_gcc.so => not found (0x0)

All these libraries are in
/usr/local/OpenOffice.org1.1.4/program, so I had
added this directory to LD_LIBRARY_PATH.

Unfortunately, this directory also has a library
libfreetype.so.9, which confuses gimp.

When I removed the LD_LIBRARY_PATH setting, gimp
behaved normally again. But now I have 'not found'
libraries with openoffice executable. Is that bad?


Do you Yahoo!? 
Yahoo! Mail - Easier than ever with enhanced search. Learn more.

More information about the freebsd-ports mailing list