Andrew J Caines A.J.Caines at
Wed Oct 1 12:56:09 PDT 2003


> /usr/X11R6/bin/mozilla: ./mozilla: Permission denied
> exec: ./mozilla: Permission denied
> Obviously it is a permissions issue, but after changing permission on
> /usr/X11R6/bin/mozilla I still get the same error.

If you had to change permissions on that file, then there's a good chance
many other files don't have right permissions. Did you install with an
unusually righteous umask?

Did you check the target, ie. /usr/X11R6/lib/mozilla/mozilla?

Look through all of /usr/X11R6/lib/mozilla{,-devel} and find all the files
which have missing `other' perms, either with find's -perm or something a
bit more legible like..

# find /usr/X11R6/lib/mozilla -ls | awk '/\-\-\-/{print $3,$NF}'

I've found that sometimes extensions will install with oddly restrictive
permissions which prevent them from being used by users.

| -Andrew J. Caines-   Unix Systems Engineer   A.J.Caines at  |
| "They that can give up essential liberty to obtain a little temporary |
|  safety deserve neither liberty nor safety" - Benjamin Franklin, 1759 |

More information about the freebsd-ports mailing list