multimedia/transcode won't build

Leslie Jensen leslie at
Mon Aug 11 11:58:38 UTC 2008

>> Thank you! I'll try the solution you mention.  Just a thought, shouldn't
>> lzo be a dependency if the port won't build without it? I my self do 
>> not have lzo installed at all at the moment and will install it just 
>> to make this new version of transcode work.
> If you haven't got any lzo installed from before I guess your simplest 
> option is to follow strategy (b) above.
> I'm not an expert on this port, I just encountered a similar problem 
> when upgrading all of my ports using "portupgrade -fa". I already had 
> lzo installed and conjured up a quick fix (a).
> <> 
> Two weeks ago the port was updated with a commit comment of "Switch from 
> using lzo to lzo2 to fix build". This was probably to work around the 
> change in the lzo header files location. It may not have been necessary, 
> as it compiled just fine for me with lzo1 and the patch. (Haven't tried 
> running it yet though.)
> I also see that if you specify the WITH_LZO it pulls in archivers/lzo2 
> as a dependency. My guess is that something in the source recently 
> changed and requires the use of lzo even when the WITH_LZO is not 
> specified.
> And here is a question for the freebsd-ports@ masters. If a port only 
> requires basic lzo functionality, is there an easy way to just work with 
> whatever version (lzo1 or lzo2) the user already has installed on the 
> system? Thus possibly avoiding the user ending up with both versions on 
> his system.
> Gyrd ^_^
>> Thanks
>> /Leslie

It worked for me with first installing lzo2 and then transcode.
Thanks for you help :-)

More information about the freebsd-multimedia mailing list