multimedia/transcode won't build

Gyrd Thane Lange gyrd-se at
Mon Aug 11 11:15:41 UTC 2008

Leslie Jensen skrev:
>> The port appears to looking for the lzo headers in the wrong place.
>> archivers/lzo places include files in /usr/local/include while
>> archivers/lzo2 places include files in /usr/local/include/lzo
>> a) To make the port work with lzo version 1, you can drop a small patch
>> file (also attached) into /usr/ports/multimedia/transcode/files/:
>> [patch-libtc_tc_lzo.h]
>> --- libtc/tc_lzo.h.orig    2008-08-10 22:24:53.000000000 +0200
>> +++ libtc/tc_lzo.h    2008-08-10 22:25:37.000000000 +0200
>> @@ -10,8 +10,8 @@
>>  #ifndef TC_LZO_H
>>  #define TC_LZO_H
>> -#include <lzo/lzo1x.h>
>> -#include <lzo/lzoutil.h>
>> +#include <lzo1x.h>
>> +#include <lzoutil.h>
>>  #ifdef HAVE_CONFIG_H
>>  #include "config.h"
>> b) You can uninstall archivers/lzo and install archivers/lzo2 instead
>> (haven' tried this but I'll expect it to work.)
>> Regards
>> Gyrd ^_^
> Thank you! I'll try the solution you mention.  Just a thought, shouldn't
> lzo be a dependency if the port won't build without it? I my self do not 
> have lzo installed at all at the moment and will install it just to make 
> this new version of transcode work.

If you haven't got any lzo installed from before I guess your simplest 
option is to follow strategy (b) above.

I'm not an expert on this port, I just encountered a similar problem 
when upgrading all of my ports using "portupgrade -fa". I already had 
lzo installed and conjured up a quick fix (a).

Two weeks ago the port was updated with a commit comment of "Switch from 
using lzo to lzo2 to fix build". This was probably to work around the 
change in the lzo header files location. It may not have been necessary, 
as it compiled just fine for me with lzo1 and the patch. (Haven't tried 
running it yet though.)

I also see that if you specify the WITH_LZO it pulls in archivers/lzo2 
as a dependency. My guess is that something in the source recently 
changed and requires the use of lzo even when the WITH_LZO is not specified.

And here is a question for the freebsd-ports@ masters. If a port only 
requires basic lzo functionality, is there an easy way to just work with 
whatever version (lzo1 or lzo2) the user already has installed on the 
system? Thus possibly avoiding the user ending up with both versions on 
his system.

Gyrd ^_^

> Thanks
> /Leslie

More information about the freebsd-multimedia mailing list