Debugging problems on amd64-current

Joshua Isom jrisom at
Fri Aug 24 00:12:09 PDT 2007

As some may remember, about a month ago I asked a question about my dvd  
drive, apparently an sata atapi drive.  Updating to a 7.0-current/amd64  
kernel did allow it to be recognized and I've been able to use it.  But  
recently I'd been noticing a kernel crash I could create.  My computer  
is headless so I didn't get any dump(savecore saved nothing).  If I  
used gdb and stepped after a segfault, it'd crash the system.  Pressing  
the power button did nothing, and pressing and holding it was required  
to get it to do something.  Although I knew there was a problem, I  
figured I'd update my world to match my kernel(a few apps didn't work  
with the mismatch but those I needed did).  It went smoothly, until I  
tried running gdb.

I currently do some work on parrot( and have  
worked on the amd64 jit for it(I prefer asm over c apparently).  To do  
this, I have to use a debugging to be able to look at the generated  
machine code.  Before, I could debug but just had to mind myself.  Now  
I can't debug the program at all.  Here's a ps snippet while running  
gdb(after running parrot).

  7316  p0  R      0:19.17 gdb parrot
  7320  p0  TX+    0:08.62 /bin/tcsh -c exec  
/usr/home/jisom/parrot/parrot -j t/compilers
  7323  p0  Z+     0:00.01 <defunct>

It does not matter what options I pass to 'run' but the program will  
not run.  The program itself will run just fine.  I tried a quick test  
of using gdb on ls and it worked just fine.  At the same time, some  
other change seems to have broken the jit I'd done, and I also can't  
debug it.  So presently my options seem to be "not see my dvd drive"  
with a 6-stable system, "dvd drive works but risky debugging and some  
stuff broken" with a 7-current kernel and a 6-stable system, or "dvd  
drive works but can't debug at all" with a 7-current system.  So far,  
the middle option seemed the best.  I'm using a GENERIC kernel not for  
safety because I didn't deal with figuring out all the options needed  
for the hardware I'd use.  Anyway, here's some of the relevant  
information that might be needed.

[freebsd:~] jisom% uname -a
FreeBSD freebsd 7.0-CURRENT FreeBSD 7.0-CURRENT #2: Wed Aug 22 07:44:19  
CDT 2007     root at freebsd:/usr/obj/usr/src/sys/GENERIC  amd64

[freebsd:~] jisom% dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
     The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-CURRENT #2: Wed Aug 22 07:44:19 CDT 2007
     root at freebsd:/usr/obj/usr/src/sys/GENERIC
WARNING: WITNESS option enabled, expect reduced performance.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 Processor 3000+ (1999.79-MHz K8-class CPU)
   Origin = "AuthenticAMD"  Id = 0xf4a  Stepping = 10
   AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow!+,3DNow!>
usable memory = 505294848 (481 MB)
avail memory  = 485785600 (463 MB)
ioapic0 <Version 0.3> irqs 0-23 on motherboard
...[etc probably less relevant]...

If any more information is wanted.  Since this is very disparaging to  
me, I'm hoping for some resolution. 

More information about the freebsd-hackers mailing list