Debugging problems on amd64-current

John Baldwin jhb at
Mon Aug 27 06:54:26 PDT 2007

On Friday 24 August 2007 03:13:08 am Joshua Isom wrote:
> As some may remember, about a month ago I asked a question about my dvd  
> drive, apparently an sata atapi drive.  Updating to a 7.0-current/amd64  
> kernel did allow it to be recognized and I've been able to use it.  But  
> recently I'd been noticing a kernel crash I could create.  My computer  
> is headless so I didn't get any dump(savecore saved nothing).  If I  
> used gdb and stepped after a segfault, it'd crash the system.  Pressing  
> the power button did nothing, and pressing and holding it was required  
> to get it to do something.  Although I knew there was a problem, I  
> figured I'd update my world to match my kernel(a few apps didn't work  
> with the mismatch but those I needed did).  It went smoothly, until I  
> tried running gdb.

Have you tried breaking into the kernel debugger?  It sounds like you've
hit a deadlock of some sort.

John Baldwin

More information about the freebsd-hackers mailing list