firefox - *** loading the extensions datasource

Sean McNeil sean at
Sat Jun 19 14:25:10 PDT 2004

On Sat, 2004-06-19 at 14:17, Georg-W. Koltermann wrote:
> Am Fr, den 18.06.2004 schrieb Sean McNeil um 9:59:
> > OK,
> > 
> > So I have firefox working as root and it doesn't print anything when I
> > run it.
> > 
> > As my regular user, it print the
> > 
> > *** loading the extensions datasource
> > 
> > and then core dumps.  I think I have some old cruft somewhere, but I
> Nobody reads release notes nowadays, I guess.  From the page at
> in section "
> Known Issues":
>       * If Firefox 0.9 is placed in a location with limited access
>         privileges, it should be run by a user with access to that
>         location first, so that all initial startup files are generated.
>         There may be issues still where if a restricted-access user is
>         the first to run the app, these files may not be generated
>         properly and Firefox may enter an infinite restart loop. This
>         will be fixed in a future release.
> Running firefox as root once did the trick for me.

Nobody reads the full thread before they comment these days, I guess :)

I did exactly that and it did NOT work for me.  I had to do some extra
things with deleting some directories before it worked.  Now, it only
"sort of" works as I have a good deal of additional problems.

The first issue I had was that cc is broken for amd64 and thunks.  I
found a fix for that.  Secondly, I got the same core dump whether I ran
with root or not.  Third, once I got root to work my user account did
NOT work and I got this message whereas I didn't get it running as root.


More information about the freebsd-gnome mailing list