i915kms broken at some commit between r296485 and r297692?

Sergey Manucharian sm at ara-ler.com
Tue May 10 23:30:18 UTC 2016

I was running FreeBSD 11.0-CURRENT r292595 on ThinkPad T430 (i7-3520M,
Intel video 4000). A couple of days ago I tried to update to a fresher

I've built the head revision and then a couple of more:
something has been broken somewhere between r296485 and r297692, 
I suspect namely i915kms - it won't boot: at the boot screen I see that
all modules are loaded, then after "Booting..." message at the bottom
screen turns black in 1-2 seconds of booting process, it seems to be the
point when it regularly switches to native resolution (with KMS).

Can anybody shed light on this? What can I check to get more details?

Regularly I update to the revisions used to build snapshots at: 


assuming that those revisions have less issues. So tried a few, none
worked for me after a certain revision from the range I mentioned above.
Now I'm on r296485.

Thanks for advices!


More information about the freebsd-current mailing list