i915kms broken at some commit between r296485 and r297692?

K. Macy kmacy at freebsd.org
Tue May 10 23:52:05 UTC 2016

I think hps@ has a fix for this that uses a sequency of DELAY()s. The
problem is that in freebsd, attach runs before the scheduler is
running. Consequently, code using sleep primitives tends to hang
because ticks never advance. The scheduler / threading starts much
earlier on linux.


On Tue, May 10, 2016 at 4:30 PM, Sergey Manucharian <sm at ara-ler.com> wrote:
> I was running FreeBSD 11.0-CURRENT r292595 on ThinkPad T430 (i7-3520M,
> Intel video 4000). A couple of days ago I tried to update to a fresher
> version.
> I've built the head revision and then a couple of more:
> something has been broken somewhere between r296485 and r297692,
> I suspect namely i915kms - it won't boot: at the boot screen I see that
> all modules are loaded, then after "Booting..." message at the bottom
> screen turns black in 1-2 seconds of booting process, it seems to be the
> point when it regularly switches to native resolution (with KMS).
> Can anybody shed light on this? What can I check to get more details?
> Regularly I update to the revisions used to build snapshots at:
> ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/ISO-IMAGES/11.0/
> assuming that those revisions have less issues. So tried a few, none
> worked for me after a certain revision from the range I mentioned above.
> Now I'm on r296485.
> Thanks for advices!
> Sergey
> _______________________________________________
> freebsd-current at freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at freebsd.org"

More information about the freebsd-current mailing list