i915kms broken at some commit between r296485 and r297692?

Sergey Manucharian sm at ara-ler.com
Fri May 13 03:23:38 UTC 2016

Excerpts from Hans Petter Selasky's message from Mon 09-May-16 19:42:
> On 05/09/16 18:10, Hans Petter Selasky wrote:
> > On 05/09/16 04:34, Sergey Manucharian wrote:
> >> I'm running FreeBSD 11.0-CURRENT r292595 on ThinkPad T430 (i7-3520M,
> >> Intel video 4000). Today I tried to update to a fresher version.
> >> Something has been broken somewhere between r296485 and r297692,
> >> I suspect namely i915kms - it won't boot: at the boot screen I see that
> >> all modules are loaded, then after "Booting..." message at the bottom
> >> screen turns black in 1-2 seconds of booting process, it seems to be the
> >> point when it regularly switches to native resolution.
> >>
> > I'm seeing the same thing with a MacBookPro. When loading drm2 and i915
> > after boot, it works. I think it is something simple causing this failure.
> >
> Can you try the attached patch. Works for me.

The patch worked for me! Thanks, Hans!


More information about the freebsd-current mailing list