7.0-RC1 fails at mountroot; 7.0-BETA4 was ok

Richard Bejtlich taosecurity at gmail.com
Wed Jan 2 08:24:28 PST 2008


I was running FreeBSD 7.0-BETA4 on a Dell Poweredge 750 and tried to
use freebsd-update to upgrade to 7.0-RC1.  I have successfully used
freebsd-update before, e.g. (albeit a different machine)


I followed these steps on the Dell.

fetch http://www.daemonology.net/freebsd-update/freebsd-update-upgrade.tgz
tar -xf freebsd-update-upgrade.tgz
sh freebsd-update.sh -f freebsd-update.conf -r 7.0-RC1 upgrade
sh freebsd-update.sh -f freebsd-update.conf install
shutdown -r now

Upon rebooting I encountered this error:

Trying to mount root from ufs:/dev/ad2s1a

Manual root filesystem specification:

If I issue the ? command I see


List of GEOM managed disk devices:
 acd0 fd0

I verified by booting the BETA4 CD that ad2s1a is the right location
for the / partition.

I next tried installing RC1 using a CD, but it failed to find any hard drive.

I finished by reinstalling BETA4 from CD, which found the hard drive.

ad2: 38146MB <Seagate ST340014AS 8.05> at ata1-master SATA150

$ df -h
Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/ad2s1a    496M    127M    329M    28%    /
devfs          1.0K    1.0K      0B   100%    /dev
/dev/ad2s1e    989M     22K    910M     0%    /home
/dev/ad2s1h     22G    4.0K     20G     0%    /nsm1
/dev/ad2s1f    989M     12K    910M     0%    /tmp
/dev/ad2s1d    4.8G    755M    3.7G    17%    /usr
/dev/ad2s1g    5.4G    242K    4.9G     0%    /var

What info can I provide to help troubleshoot this problem?

Thank you,


More information about the freebsd-current mailing list