ural && HPS usb stack

Marinos Ilias marinosi at ceid.upatras.gr
Sat May 5 16:54:46 UTC 2007


Hello people,
	I have a Dell XPS m1210 and because it has intel wireless 3945ABG, which doesn't work for me using the wpi driver, I decided to buy a Gigabyte GN-WBKG wireless usb adapter.It is recognized normally with ural driver.
	The last 3 weeks I had some weird problems using this usb adapter.While I was surfing or listening to radio (from internet) the laptop many times suddenly rebooted(a reboot like a hardware reset , which didn't give me the chance to catch the errors).Also I am not sure how can I reproduce the error in a way that I can understand what crashes.
	So I decided , to test the HPS usb stack .Now I don't have these "reboots" any more but sometimes after a lot of use it seems the device does not respond.Something has to do with the ural driver.At such a moment I get the interface down and detach and re-attach the stick but kernel does not see it anymore and I have to reboot the whole system.I paste to you some messages :


marinosi at lucifer:~$ dmesg | grep ural
ural0: <Ralink 802.11g WLAN + Pen Drive, class 0/0, rev 2.00/0.01, addr 126>
ural0: at uhub4 port 2 (addr 126) disconnected
ural0: MAC/BBP RT2570 (rev 0x05), RF RT2526
ural0: Ethernet address: 00:16:e6:3e:b3:f8
ural0: detached
ural0: <Ralink 802.11g WLAN + Pen Drive, class 0/0, rev 2.00/0.01, addr 126>
ural0: MAC/BBP RT2570 (rev 0x05), RF RT2526
ural0: Ethernet address: 00:16:e6:3e:b3:f8
ural0: link state changed to UP
ural0: at uhub4 port 2 (addr 126) disconnected
ural0: link state changed to DOWN
ural0: detached
ural0: <Ralink 802.11g WLAN + Pen Drive, class 0/0, rev 2.00/0.01, addr 126>
ural0: MAC/BBP RT2570 (rev 0x05), RF RT2526
ural0: Ethernet address: 00:16:e6:3e:b3:f8
ural0: at uhub4 port 2 (addr 126) disconnected
ural0: detached
ural0: <Ralink 802.11g WLAN + Pen Drive, class 0/0, rev 2.00/0.01, addr 126>
ural0: MAC/BBP RT2570 (rev 0x05), RF RT2526
ural0: Ethernet address: 00:16:e6:3e:b3:f8
ural0: at uhub4 port 2 (addr 126) disconnected
ural0: detached
ural0: <Ralink 802.11g WLAN + Pen Drive, class 0/0, rev 2.00/0.01, addr 126>
ural0: could not set configuration number, err=USBD_TIMEOUT!
device_attach: ural0 attach returned 6



marinosi at lucifer:~$ sudo wpa_supplicant -i ural0 -c /etc/wpa_supplicant.conf 
Failed to initialize driver interface
 
 IIRC , after this incident the usb port is fully disabled.I want to note , that this happens without moving the usb adapter at all.

Thank you all and have a nice time.

--Ilias 


More information about the freebsd-current mailing list