USB mouse works again in current!!!

Hans Petter Selasky hselasky at c2i.net
Tue Jun 26 12:55:39 UTC 2007


Hi Ian,

On Tuesday 26 June 2007 14:03, Ian FREISLICH wrote:
> Hans Petter Selasky wrote:
> > Hi Ian,
> >
> > Debugging Host Controller Halted is not so easy. It usually means that
> > the DMA memory corrupted.
>
> I gathered it's not that easy.  The controller that breaks is this one:
>
> uhci3 at pci0:29:3:        class=0x0c0300 card=0x72708086 chip=0x27cb8086
> rev=0x02 hdr=0x00 vendor     = 'Intel Corporation'
>     device     = '82801G (ICH7 Family) USB Universal Host Controller'
>     class      = serial bus
>     subclass   = USB
>
> uhci3: <UHCI (generic) USB controller> port 0x4040-0x405f irq 16 at device
> 29.3 on pci0 uhci3: [GIANT-LOCKED]
> uhci3: [ITHREAD]
> uhci3: LegSup = 0x1010
> usb3: <UHCI (generic) USB controller> on uhci3
> usb3: USB revision 1.0
> usbd_get_string: getting lang failed, using 0
> uhub3: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
> uhub3: 2 ports with 2 removable, self powered
>
> > Have you tried my new USB stack, popularly called HPS USB stack ?
>
> No, I'm going to try that now.  I'm assuming it's:
> http://www.turbocat.net/~hselasky/usb4bsd/

Yes, that is correct.

If you are building with the latest FreeBSD-7 current, then be aware that it 
might break. You need to zero at least "/usr/src/sys/dev/usb/umass.c" after 
installation.

In general, just zero out the files that won't compile, if you get any build 
errors.

HINT: Use the "-k" option after "make" to get all the compile errors in one 
go:

tcsh
cd /usr/src
make -k buildkernel KERNCONF=custom -DNOCLEAN -DNO_CLEAN >& compile_log.txt

Else my USB stack compiles fine on FreeBSD 6.2.

--HPS

>
> I tried building 1.6.1, but I got the following:

That is an old version. There has been many changes since that release.

>
> So I'm trying the latest.
>
> > And what kind of platform are you using?
>
> It's an Apple MacBook Pro.
>

Ok.

--HPS


More information about the freebsd-current mailing list