USB mouse works again in current!!!

Ian FREISLICH ianf at clue.co.za
Tue Jun 26 12:04:09 UTC 2007


Hans Petter Selasky wrote:
> Hi Ian,
> 
> Debugging Host Controller Halted is not so easy. It usually means that
> the DMA memory corrupted.

I gathered it's not that easy.  The controller that breaks is this one:

uhci3 at pci0:29:3:        class=0x0c0300 card=0x72708086 chip=0x27cb8086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB Universal Host Controller'
    class      = serial bus
    subclass   = USB

uhci3: <UHCI (generic) USB controller> port 0x4040-0x405f irq 16 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
uhci3: [ITHREAD]
uhci3: LegSup = 0x1010
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
usbd_get_string: getting lang failed, using 0
uhub3: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered

> Have you tried my new USB stack, popularly called HPS USB stack ?

No, I'm going to try that now.  I'm assuming it's:
http://www.turbocat.net/~hselasky/usb4bsd/

I tried building 1.6.1, but I got the following:

===> axe (all)
cc -O2 -fno-strict-aliasing -pipe -march=pentium4  -D_KERNEL -DKLD_MODULE -std=c
99 -nostdinc   -DHAVE_KERNEL_OPTION_HEADERS -include /usr/obj/usr/src/sys/APPLE/
opt_global.h -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-gr
owth=100 --param large-function-growth=1000 -fno-common -g -I/usr/obj/usr/src/sy
s/APPLE -mno-align-long-strings -mpreferred-stack-boundary=2  -mno-mmx -mno-3dno
w -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -Wall -Wredundant-decls -Wnested-e
xterns -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast
-qual  -Wundef -Wno-pointer-sign -fformat-extensions -c /usr/src/sys/modules/axe
/../../dev/usb/if_axe.c
In file included from @/dev/usb2/usb.h:49,
                 from @/dev/usb/usb.h:1,
                 from /usr/src/sys/modules/axe/../../dev/usb/if_axe.c:93:
@/dev/usb2/usb_port.h:292:1: warning: "msleep" redefined
In file included from /usr/src/sys/modules/axe/../../dev/usb/if_axe.c:71:
@/sys/systm.h:307:1: warning: this is the location of the previous definition
/usr/src/sys/modules/axe/../../dev/usb/if_axe.c:717:65: error: macro "usb_add_ta
sk" passed 3 arguments, but takes just 2
/usr/src/sys/modules/axe/../../dev/usb/if_axe.c: In function 'axe_tick':
/usr/src/sys/modules/axe/../../dev/usb/if_axe.c:717: error: 'usb_add_task' undec
lared (first use in this function)
/usr/src/sys/modules/axe/../../dev/usb/if_axe.c:717: error: (Each undeclared ide
ntifier is reported only once
/usr/src/sys/modules/axe/../../dev/usb/if_axe.c:717: error: for each function it
 appears in.)
*** Error code 1
1 error
*** Error code 2
1 error
*** Error code 2
2 errors
*** Error code 2
1 error
*** Error code 2
1 error

So I'm trying the latest.

> And what kind of platform are you using?

It's an Apple MacBook Pro.

Ian

--
Ian Freislich



More information about the freebsd-current mailing list