Problems in current *or have you seen this?

Kevin Oberman oberman at
Fri Apr 20 20:10:10 UTC 2007

> Date: Thu, 19 Apr 2007 19:42:14 -0400
> From: Randall Stewart <rrs at>
> Sender: owner-freebsd-current at
> Hi all:
> I have a few problems with current. And I am
> wondering if anyone else has seen these.
> Now, I run my IBM T43 thinkpad on current. Yes I know
> I am brave (ha ha). But I like to work on current and SCTP
> on planes.. its seems one of the only ways I get things done.
> Christmas this past year, I decided to reload/rebuild everything
> since I had a 80Gig disk that I had put to the side when my
> new laptop arrived sticking my 60 Gig in..
> So I saved off all my stuff. Loaded 6.1 (6.2 was not out
> if I remember right.. or i was lazy).
> Drug out the cvs repository via cvsup. Went through and
> built a kernel... built the world .. installed it.. and
> then started building all the packages I use (like openoffice
> etc). Lots of fun.
> At the end I rebooted and up came X very nicely.. and here
> my first problem occurred
> A) I could not log in. Every time I try it tells me some pam module
>     cannot be loaded. Even though I can see the lib/ that it
>     is complaining about. So, what do I do to fix it. I go to
>     an older 7.0 machine I had that x was fine on.. and copied in
>     the pam libs overwriting the ones I had just built. Ta-da I
>     can log in. I even just recently rebuilt and re-installed from
>     the latest current ..(buildworld).. and still I had the pam
>     problem (but of course now I keep the old pam libs in my home
>     dir so its a quick copy). As anyone seen this one??

This sounds like problems with source inconsistency. If you csup
something that has files that were loaded from some other source, csup
won't delete files that are no longer in CVS. csup will only delete
files it created.

I suggest that you delete the entire source tree the first time you
update after a new install so that this does not happen. This applies to
both src and ports.

> B) When I got to Melbourne to teach a SCTP class .. I found my second
>     X'y problem. In all the time past, I easily plug in to projectors.
>     Hit alt-F7 and out goes my 1024x768 display.. and on with the show
>     :-D.. but when I got to the class room. Hit it all.. nothing. After
>     much fussing the only thing I found I could do was reboot my machine
>     with the projector up.. thus turning off the display and forcing
>     it out the beamer.. but it was stuck in 640x480 mode. Ugly and no
>     way does that work. I figured it might be their projector.. so we
>     used someones mac.. messed up fonts.. but oh well it worked. The
>     MAC also had some issues.. (but could project 1024).. So I get to
>     BSD-Asia last month.. thinking it was the projector.. and tada.. same
>     problem... I had to use a friends window's box (yuck). So is there
>     some magic cookie I need in X.. that somehow got lost in the new
>     load? I did have to disable drm in the file to keep it from crashing
>     on x exiting... or am I just doomed to not be able to project forever
>     :-(

FWIW, my T43 has the same problem. I'd love to see a solution to this

> C) So to add fun today I plugged in a USB stick to give someone some
>     code and down the machine crashed in the cam code.. trying to
>     lock a null mutex pointer. I think this is just a temporary thing
>     and I am doing a cvsup /rebuild now.. which I think will clear that
>     issue (since I have seen commits go in on those files ;-D)

Scott has just committed several fixes that should take care of this.

> Do I need to get a new ports tree... or ??

Same csup issues as with src, but, because of the way patches are
heavily used in ports, far more likely to bite. I no longer install
ports from the distro at all. I just csup them after I install. This
used to be a pain when cvsup had to be installed, but csup is in the
base system, so it's easy now. (Probably portsnap would work even better,
but I still have not gotten around to trying it.)
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at			Phone: +1 510 486-8634
Key fingerprint:059B 2DDF 031C 9BA3 14A4  EADA 927D EBB3 987B 3751
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 224 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list