Problems in current *or have you seen this?

Randall Stewart rrs at
Thu Apr 19 23:40:01 UTC 2007

Hi all:

I have a few problems with current. And I am
wondering if anyone else has seen these.

Now, I run my IBM T43 thinkpad on current. Yes I know
I am brave (ha ha). But I like to work on current and SCTP
on planes.. its seems one of the only ways I get things done.

Christmas this past year, I decided to reload/rebuild everything
since I had a 80Gig disk that I had put to the side when my
new laptop arrived sticking my 60 Gig in..

So I saved off all my stuff. Loaded 6.1 (6.2 was not out
if I remember right.. or i was lazy).

Drug out the cvs repository via cvsup. Went through and
built a kernel... built the world .. installed it.. and
then started building all the packages I use (like openoffice
etc). Lots of fun.

At the end I rebooted and up came X very nicely.. and here
my first problem occurred

A) I could not log in. Every time I try it tells me some pam module
    cannot be loaded. Even though I can see the lib/ that it
    is complaining about. So, what do I do to fix it. I go to
    an older 7.0 machine I had that x was fine on.. and copied in
    the pam libs overwriting the ones I had just built. Ta-da I
    can log in. I even just recently rebuilt and re-installed from
    the latest current ..(buildworld).. and still I had the pam
    problem (but of course now I keep the old pam libs in my home
    dir so its a quick copy). As anyone seen this one??

B) When I got to Melbourne to teach a SCTP class .. I found my second
    X'y problem. In all the time past, I easily plug in to projectors.
    Hit alt-F7 and out goes my 1024x768 display.. and on with the show
    :-D.. but when I got to the class room. Hit it all.. nothing. After
    much fussing the only thing I found I could do was reboot my machine
    with the projector up.. thus turning off the display and forcing
    it out the beamer.. but it was stuck in 640x480 mode. Ugly and no
    way does that work. I figured it might be their projector.. so we
    used someones mac.. messed up fonts.. but oh well it worked. The
    MAC also had some issues.. (but could project 1024).. So I get to
    BSD-Asia last month.. thinking it was the projector.. and tada.. same
    problem... I had to use a friends window's box (yuck). So is there
    some magic cookie I need in X.. that somehow got lost in the new
    load? I did have to disable drm in the file to keep it from crashing
    on x exiting... or am I just doomed to not be able to project forever

C) So to add fun today I plugged in a USB stick to give someone some
    code and down the machine crashed in the cam code.. trying to
    lock a null mutex pointer. I think this is just a temporary thing
    and I am doing a cvsup /rebuild now.. which I think will clear that
    issue (since I have seen commits go in on those files ;-D)

Has anyone seen A/B .. and if you have whats the fix?

Do I need to get a new ports tree... or ??

Help if someone knows how to fix it would be nice.. I hate having
to do my pam workaround since I know eventually that will not
work.. and the projector thing is a real pain.. especially with
the amount I travel and have to present.

Any clues would be greatly appreciated.. even pointers to
RTFM and this is the man page you stupid idiot.. would be



Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 803-317-4952 (cell)

More information about the freebsd-current mailing list