mplayer audio chokes on LOTR DVD

supraexpress at globaleyes.net supraexpress at globaleyes.net
Sun Sep 18 22:41:40 PDT 2005


In the past, I used to be able to play the LOTR DVD's without any problem.
Now, I keep getting "Couldn't find matching filter/ao format!" error
messages, no matter what sound module/driver I choose, and then all I get is
a loud buzz/hum. Playing OTHER types of DVDs, that apparaently use a
different audio codec, work just fine.


cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <Creative EMU10K1> at io 0xe400 irq 18 kld snd_emu10k1 (4p/2r/4v channels duplex default)


gmplayer
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Cannot find codec 'dts' in libavcodec...
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
No accelerated IMDCT transform found
hwac3: switched to DTS, 768000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, ac3, 768.0 kbit/50.00% (ratio: 96000->192000)
Selected audio codec: [hwdts] afm:hwac3 (DTS through S/PDIF)
==========================================================================
xscreensaver_disable: xscreensaver wid=10485761.
Opening video filter: [pp]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
[PP] Using external postprocessing filter, max q = 6.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
[PP] Using external postprocessing filter, max q = 6.
Checking audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
[format] Sample format big-endian AC3 not yet supported
Error at audio filter chain pre-init!
[AO OSS] Can't set audio device /dev/dsp0.0 to ac3 output, trying s16le...
AO: [oss] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/s16le...
[format] Sample format big-endian AC3 not yet supported
Couldn't find matching filter/ao format!


More information about the freebsd-current mailing list