mplayer audio chokes on LOTR DVD

Pav Lucistnik pav at FreeBSD.org
Mon Sep 19 01:05:03 PDT 2005


supraexpress at globaleyes.net píše v po 19. 09. 2005 v 00:41 -0500:

> In the past, I used to be able to play the LOTR DVD's without any problem.
> Now, I keep getting "Couldn't find matching filter/ao format!" error
> messages, no matter what sound module/driver I choose, and then all I get is
> a loud buzz/hum. Playing OTHER types of DVDs, that apparaently use a
> different audio codec, work just fine.

> Cannot find codec 'dts' in libavcodec...

> Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
> No accelerated IMDCT transform found
> hwac3: switched to DTS, 768000 bps, 48000 Hz
> AUDIO: 48000 Hz, 2 ch, ac3, 768.0 kbit/50.00% (ratio: 96000->192000)
> Selected audio codec: [hwdts] afm:hwac3 (DTS through S/PDIF)

I noticed this too, it's trying to play a DTS audio track, it can't open
an DTS decoder so it tried to send raw DTS data to S/PDIF output on your
soundcard.

I don't think this is FreeBSD problem, it's more likely an mplayer
problem.

-- 
Pav Lucistnik <pav at oook.cz>
              <pav at FreeBSD.org>

Mischief managed.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050919/2ef9c3c7/attachment.bin


More information about the freebsd-current mailing list