6.0-CURRENT SNAP004 hangs on amr (patch)

Marc Olzheim marcolz at stack.nl
Thu Aug 4 10:22:17 GMT 2005


On Wed, Aug 03, 2005 at 03:15:57PM +0200, Marc Olzheim wrote:
> On Wed, Aug 03, 2005 at 09:01:19AM -0400, Mike Tancsa wrote:
> > At 08:14 AM 03/08/2005, Marc Olzheim wrote:
> > 
> > >That still doesn't work. Dmesg of a boot -v on the kernel without ATA is
> > >at
> > >http://www.stack.nl/~marcolz/FreeBSD/freebsd-6-amr-1123071090.dmesg.txt
> > >
> > >at least, until it hangs itself again.
> > >
> > >I've never run 5 on it, so I don't know if that works or not.
> > 
> > Actually, I have the Adaptec SCSI controller disabled in my BIOS and I also 
> > updated the BIOS to the latest from the dell support site.  Can you try 
> > that as well?
> 
> Erhm, I boot from that Adaptec. :-/ But I can try if it can boot the
> kernel with it disabled. ;-)

None of which work.

A kernel with no ata and no ahc gives me:

...
sn0: not probed (disabled)
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
vt0: not probed (disabled)
isa_probe_children: probing PnP devices
Device configuration finished.
procfs registered
lapic: Divisor 2, Frequency 66497255 hz
Timecounter "TSC" frequency 997465745 Hz quality -100
Timecounters tick every 1.000 msec
lo0: bpf attached
---------------------< Here it stops if I plugin the amr > -----------------
SMP: AP CPU #1 Launched!
cpu1 AP:
     ID: 0x00000000   VER: 0x00040011 LDR: 0x01000000 DFR: 0x0fffffff
  lint0: 0x00010700 lint1: 0x00000400 TPR: 0x00000000 SVR: 0x000001ff
  timer: 0x000200ef therm: 0x00000000 err: 0x00010000 pcm: 0x00010000
ioapic0: routing intpin 1 (ISA IRQ 1) to cluster 0
ioapic0: routing intpin 3 (ISA IRQ 3) to cluster 0
ioapic0: routing intpin 4 (ISA IRQ 4) to cluster 0
ioapic0: routing intpin 6 (ISA IRQ 6) to cluster 0
ioapic0: routing intpin 7 (ISA IRQ 7) to cluster 0
ioapic0: routing intpin 9 (ISA IRQ 9) to cluster 0
ioapic0: routing intpin 13 (ISA IRQ 13) to cluster 0
ioapic1: routing intpin 0 (PCI IRQ 16) to cluster 0
ioapic1: routing intpin 1 (PCI IRQ 17) to cluster 0
Trying to mount root from ufs:/dev/da0s1a

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot>

boot -v for the kernel with no ata and no ahc *with amr plugged in*:
http://www.stack.nl/~marcolz/FreeBSD/freebsd-6-amr-1123150616.dmesg.txt

boot -v for the kernel with no ata and no ahc *with no amr plugged in*:
http://www.stack.nl/~marcolz/FreeBSD/freebsd-6-amr-1123150616-2.dmesg.txt

Marc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050804/b08379dc/attachment.bin


More information about the freebsd-current mailing list