6.0-CURRENT SNAP004 hangs on amr (patch)

John Baldwin jhb at FreeBSD.org
Thu Aug 4 13:45:05 GMT 2005


On Thursday 04 August 2005 06:22 am, Marc Olzheim wrote:
> On Wed, Aug 03, 2005 at 03:15:57PM +0200, Marc Olzheim wrote:
> > On Wed, Aug 03, 2005 at 09:01:19AM -0400, Mike Tancsa wrote:
> > > At 08:14 AM 03/08/2005, Marc Olzheim wrote:
> > > >That still doesn't work. Dmesg of a boot -v on the kernel without ATA
> > > > is at
> > > >http://www.stack.nl/~marcolz/FreeBSD/freebsd-6-amr-1123071090.dmesg.tx
> > > >t
> > > >
> > > >at least, until it hangs itself again.
> > > >
> > > >I've never run 5 on it, so I don't know if that works or not.
> > >
> > > Actually, I have the Adaptec SCSI controller disabled in my BIOS and I
> > > also updated the BIOS to the latest from the dell support site.  Can
> > > you try that as well?
> >
> > Erhm, I boot from that Adaptec. :-/ But I can try if it can boot the
> > kernel with it disabled. ;-)
>
> None of which work.
>
> A kernel with no ata and no ahc gives me:

Hmm, on your machine amr0 gets IRQ 18, where as on Mike's machine it got IRQ 
14 (which was very odd and I think related to his problems with ata(4)).  
Which patch are you using, btw, and if you are using the one that was 
committed, are you setting the 'hw.apic.enable_extint=1' tunable from the 
loader?

-- 
John Baldwin <jhb at FreeBSD.org>  <><  http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve"  =  http://www.FreeBSD.org


More information about the freebsd-current mailing list