ATA DVD playback hanging in physrd

Nate Lawson nate at
Wed Sep 1 13:59:38 PDT 2004

Søren Schmidt wrote:
> Kevin Oberman wrote:
>> Nate,
>> By the way, as of the moment, almost everything on my T30 for S3
>> suspend/resume is working correctly. I can suspend and resume repeatedly
>> with no problem except for the failure of the ICH3/AD1881A sound device
>> to properly re-initialize. It worked for about a week when Warner first
>> put in the PCI power stuff, but it never worked again after he backed
>> out the initial attempt and re-committed stuff bit by bit over time.
>> I assume that this is really a PCI issue and not really ACPI. I'll
>> remind Warner of the problem some day after 5.3 is released and the
>> ensuing confusion fades.
>> Still, this is a major improvement as the system is generally usable
>> after a suspend. Just no listen-able music. :-(
>> Thanks for all of the efforts on making ACPI work on the morass of
>> buggy, uncomplete, and just plain obstinate implementations out there.
> On that note ACPI still locks hard both my laptops (ASUS/Acer) on 
> resume, with and upto date -current its back to not even switching on 
> the backlight, so I have no way to tell what happens. On the ASUS that 
> has a serial port even that is totally dead.
> However, commenting out the resume code in acpi_cmbat.c make it get so 
> far as to give me a prompt in singleuser mode, but just a simple ls 
> makes in crash with a double fault in the image activation of the ls 
> command, it looks like the vm system is way out to lunch somehow.

Try taking /sys/i386/acpi_wakeup.c back to 1.36.  If that doesn't work, 
try reverting /sys/dev/acpica/acpi.c back to 2004/8/1 (mentioned 
previously).  It is important to isolate the cause.

I'm working on the cmbat resume part for you.  The reason why this is 
not an easy problem to debug is that different systems have different 
AML and that AML is run by various methods, including cmbat.  If it does 
weird things like writing to various runtime registers or acquiring 
mutexes, it can cause failures independent of our code.  My laptop 
suspends/resumes fine with -current, including hotplugging the 
batteries, etc.


More information about the freebsd-current mailing list