5.3-BETA7 ISO wont load after install (stuck after bootloader)

Luke luked at pobox.com
Mon Oct 11 20:40:06 PDT 2004

On Mon, 11 Oct 2004, Mike Jakubik wrote:

> Date: Mon, 11 Oct 2004 23:10:52 -0400 (EDT)
> From: Mike Jakubik <mikej at rogers.com>
> To: LukeD at pobox.com
> Cc: freebsd-current at freebsd.org
> Subject: Re: 5.3-BETA7 ISO wont load after install (stuck after bootloader)
> Luke said:
>> On Mon, 11 Oct 2004, Mike Jakubik wrote:
>>> I have booted the install in safe mode, and completed another install.
>>>  Same problem. The machine has 1GB of RAM. I will try downloading a
>>> 4.10 CD and installing that. Another thing i noticed which may or may
>>> not be related is this error message (the machine is a single cpu
>>> athlon):
>>> mptable_probe: MP Config Table has bad signature: <ASCII smiley face>
>>> Thanks.
>> I had that exact same error and behavior with 5.2.1 back in March.   I
>> had to disable SMP and APIC in the kernel in order to boot the machine.
>> The "boot without APIC" on the startup menu worked until I was able to
>> build a custom kernel.
>> Something in the SMP code just could not get along with the motherboard
>> on that machine.  Considering the age, condition, and technological
>> oddness of the motherboard, I can't really blame the code for my problem
>> however.
> This is not the same problem, i do not get to that stage of the boot. The
> install CD boots fine. I think you mean ACPI.

You're right.  I am confused.  It was safe mode that let me boot, not the 
"no ACPI" option on the boot menu.  Like I said, it's been a few months.

My problem really was SMP + APIC though.

If safe mode is working for you, but normal mode gives you the 
mptable_probe error, my recommendation is still to compile a custom kernel 
without SMP and APIC.  Since it's a single-processor system, you don't 
need them anyway.  If I understand anything I've read correctly, there 
won't be an mptable_probe if you don't try to run an SMP kernel.

More information about the freebsd-current mailing list