VIA 8235 UDMA ICRC errors

Yura Socolov fbsd-current.z.yurasocolov at
Tue Apr 13 19:43:20 PDT 2004

On Tue, Apr 13, 2004 at 09:03:15AM +0200, Martin Hudec wrote:
> 	I did see the same error, but it was caused by bad ide controller on
> mainboard. Check cable connections, replace the cables, download and use
> vendor's diagnostic utility.

I've tried replacing pretty much everything, including power supplies, drives
and motherboards. And even versions of FreeBSD. If it has a 8235, it doesn't 
work, period.

After talking off-line with Doug White, though, i am under impression that it
has something to do with the size of the drive as well. He says his kt400/8235
works fine with an 80G drive. All my test drives have been 160G, and i don't 
have a smaller drive that could do UDMA100. All of them failed on my kt400/8235.

I solved it for myself by getting a KT600/8237 motherboard (DFI), and i still 
think something is very fishy about 8235. Unfortunately, though, i don't have 
resources to verify that or troubleshoot it further. I spent a week on this 

Thank you for your advice, and the same goes to Doug White. Appreciate your help
very much.

-- Yura Socolov <nospam>                   FP: A7192ABD96E15F5 19AB21E60C34109
-- Opinions and views in this message are my own and my own only.
-- "Two wrongs don't make a right... and three rights make a left." -- TRACON

> On Thu, Apr 08, 2004 at 11:26:11PM -0500 or thereabouts, Yura Socolov wrote:
> > Following is a message i sent to -hardware last night. I have since tried 
> > this on -current as of today and,  since i  get the same kind of behavior, i 
> > thought i'd ask here as well.
> > 
> > The errors i'm getting are like this:
> > 
> > ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
> > ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
> > ad0: FAILURE - WRITE_DMA status=51<READY,DSC,ERROR> error=84<ICRC,ABORTED> LBA=297945007
> > 
> > Errors seem to snowball after a few minutes after boot, unless bg fsck kicks 
> > in, in which case they are there right away.
> > 
> > This is on a Shuttle AK32VN motherboard (KT266, 8235) with a samsung 160G disk,
> > but as mentioned below other VIA-based motherboads manifest the dame problems.
> > 
> > I guess question at this point is whether this is something that's temporarily
> > broken, bad hardware (but it works with other motherboards), something that is
> > no longer supported or something else.
> > 
> > Or i'm doing something wrong.
> > 
> > Any advice would be appreciated, thank you.
> -- 
> Martin Hudec		| corwin at
> 			| corwin at
>	| cell +421 907 303 393

More information about the freebsd-current mailing list