VIA 8235 UDMA ICRC errors

Søren Schmidt sos at
Wed Apr 14 05:59:08 PDT 2004

Yura Socolov wrote:
> I've tried replacing pretty much everything, including power supplies, drives
> and motherboards. And even versions of FreeBSD. If it has a 8235, it doesn't 
> work, period.
> After talking off-line with Doug White, though, i am under impression that it
> has something to do with the size of the drive as well. He says his kt400/8235
> works fine with an 80G drive. All my test drives have been 160G, and i don't 
> have a smaller drive that could do UDMA100. All of them failed on my kt400/8235.
> I solved it for myself by getting a KT600/8237 motherboard (DFI), and i still 
> think something is very fishy about 8235. Unfortunately, though, i don't have 
> resources to verify that or troubleshoot it further. I spent a week on this 
> already.

Hmm, it could be that there are problems with the 8235 and 48bit mode 
needed for >137G drives.
However, I dont have a 8235 in my ATA HW collection so I have no way of 
reproducing/testing/fixing this problem if thats the case.
On top of that VIA is not very cooperative so getting docs that could 
help here is not very likely..


More information about the freebsd-current mailing list