VIA 8253 UDMA ICRC errors

Martin Hudec corwin at
Tue Apr 13 00:02:10 PDT 2004

Hello Yura,

	I did see the same error, but it was caused by bad ide controller on
mainboard. Check cable connections, replace the cables, download and use
vendor's diagnostic utility.



On Thu, Apr 08, 2004 at 11:26:11PM -0500 or thereabouts, Yura Socolov wrote:
> Following is a message i sent to -hardware last night. I have since tried 
> this on -current as of today and,  since i  get the same kind of behavior, i 
> thought i'd ask here as well.
> The errors i'm getting are like this:
> ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
> ad0: WARNING - WRITE_DMA UDMA ICRC error (retrying request) LBA=297945007
> ad0: FAILURE - WRITE_DMA status=51<READY,DSC,ERROR> error=84<ICRC,ABORTED> LBA=297945007
> Errors seem to snowball after a few minutes after boot, unless bg fsck kicks 
> in, in which case they are there right away.
> This is on a Shuttle AK32VN motherboard (KT266, 8235) with a samsung 160G disk,
> but as mentioned below other VIA-based motherboads manifest the dame problems.
> I guess question at this point is whether this is something that's temporarily
> broken, bad hardware (but it works with other motherboards), something that is
> no longer supported or something else.
> Or i'm doing something wrong.
> Any advice would be appreciated, thank you.

Martin Hudec		| corwin at
			| corwin at	| cell +421 907 303 393

More information about the freebsd-current mailing list