USB issues -- dodgy motherboard?

Bernd Walter ticso at
Thu Apr 8 02:57:25 PDT 2004

On Wed, Apr 07, 2004 at 07:32:59PM +0100, Nik Clayton wrote:
> On Tue, Apr 06, 2004 at 10:45:22AM -0700, Doug White wrote:
> > I have an IBM machine at work with this southbridge and it happily talks
> > to a Lexar usb key, so I suspect interrupt problems.
> > 
> > Have you tried it after booting with ACPI disabled?
> I just tried with
>     hint.acpi.0.disabled="1"
> in /boot/device hints.  The boot got this far through the process:
>     [...]
>     uhci0: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 10 at device 7.2 on pci0
>     usb0: <VIA 83C572 USB controller> on uhci0
>     usb0: USB revision 1.0
>     uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
>     uhub0: 2 ports with 2 removable, self powered
> and then hung.  I left it for five minutes, no activity, and no response
> on the keyboard, so I hit the reset button.  For reference, the next
> lines in the boot sequence with ACPI enabled are:

>     uhub1: Atmel Standard USB Hub, class 9/0, rev 1.10/3.00, addr 2
>     uhub1: 4 ports with 4 removable, self powered

So here is the difference - the Atmel hub don't show up in the problem
It's having problems with the connected hub device.
Is this 100% reproduceable or just from time to time?
Does the hub really have it's own power supply as it claims?
Please retry with a USB_DEBUG kernel - in case of a broken device the
probing may take serveral minutes - maybe we should give some output
without USB_DEBUG too in this case.

>     uhci1: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 10 at device 7.3 on pci0

This is another controller.

B.Walter                   BWCT      
ticso at                                  info at

More information about the freebsd-current mailing list