USB issues -- dodgy motherboard?

Nik Clayton nik at
Wed Apr 7 11:33:56 PDT 2004

On Tue, Apr 06, 2004 at 10:45:22AM -0700, Doug White wrote:
> I have an IBM machine at work with this southbridge and it happily talks
> to a Lexar usb key, so I suspect interrupt problems.
> Have you tried it after booting with ACPI disabled?

I just tried with


in /boot/device hints.  The boot got this far through the process:

    uhci0: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 10 at device 7.2 on pci0
    usb0: <VIA 83C572 USB controller> on uhci0
    usb0: USB revision 1.0
    uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered

and then hung.  I left it for five minutes, no activity, and no response
on the keyboard, so I hit the reset button.  For reference, the next
lines in the boot sequence with ACPI enabled are:

    uhub1: Atmel Standard USB Hub, class 9/0, rev 1.10/3.00, addr 2
    uhub1: 4 ports with 4 removable, self powered
    uhci1: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 10 at device 7.3 on pci0
    usb1: <VIA 83C572 USB controller> on uhci1
    usb1: USB revision 1.0
    uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 2 ports with 2 removable, self powered

I've put the most recent full boot log at

FreeBSD: The Power to Serve               (__)
FreeBSD Documentation Project    \\\'',)
                                                                      \/  \ ^
   --- 15B8 3FFC DDB4 34B0 AA5F  94B7 93A8 0764 2C37 E375 ---         .\._/_)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list