DStumbler / BSD-AirTools Error with new Wi code?

Sean Chittenden sean at chittenden.org
Wed Nov 19 17:33:18 PST 2003

> I have been getting the following error when attempting to use dstumbler 
> with 5.1-RELEASE-p10: 
> error: unable to ioctl device socket: Invalid argument 
> After much searching around newsgroups/mailing lists it looks like the 
> Wi(4) code was changed and dstumbler never got updated. I found one patch 
> that supposedly fixed support on some cards, however, it didn't seem to 
> work on mine. Has anyone worked on this in -current? Or does anyone know of 
> patches that aren't in CVS yet that might work? 
> Here is my info:
> lilshadow# dmesg |grep wi0
> wi0: <Dell TrueMobile 1150 Series PC Card> at port 0x100-0x13f irq 11 
> function 0 config 1 on pccard2
> wi0: 802.11 address: 00:02:2d:84:22:18
> wi0: using Lucent Embedded WaveLAN/IEEE
> wi0: Lucent Firmware: Station (8.10.1)
> wi0: supported rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 
> Wireless card works fine otherwise. 

Have you tried just `dstumbler wi0` ?  I need the -o with my Netgear

$ dmesg | grep wi0
wi0: <NETGEAR MA401 Wireless PC Card> at port 0x100-0x13f irq 11 function 0 config 1 on pccard0
wi0: 802.11 address: 00:30:ab:11:f6:88
wi0: using RF:PRISM2 MAC:HFA3841 CARD:HWB3163 rev.A
wi0: Intersil Firmware: Primary (0.3.0), Station (0.8.3)
wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
$ sudo dstumbler wi0 -o
[fires up]

I don't know if Lucent cards are supported or not.  How old is your
kernel, btw?  You should update to -CURRENT as there have been many
wlan fixes since 5.1-RELEASE.  -sc

Sean Chittenden

More information about the freebsd-current mailing list