DStumbler / BSD-AirTools Error with new Wi code?

Ryan Sommers ryans at gamersimpact.com
Wed Nov 19 17:21:00 PST 2003


I upgraded to 0.3 and installed. However, I'm still getting errors no matter 
how I run it: 

dstumbler wi0 -o
error: cannot use monitor mode on non-prism2 cards 

dstumbler wi0 -s
error: unable to ioctl device socket: Invalid argument 

same for just running dstumbler wi0. 

Any ideas? 

Sean Chittenden writes: 

>> I have been getting the following error when attempting to use dstumbler 
>> with 5.1-RELEASE-p10:  
>> 
>> error: unable to ioctl device socket: Invalid argument  
>> 
>> After much searching around newsgroups/mailing lists it looks like the 
>> Wi(4) code was changed and dstumbler never got updated. I found one patch 
>> that supposedly fixed support on some cards, however, it didn't seem to 
>> work on mine. Has anyone worked on this in -current? Or does anyone know of 
>> patches that aren't in CVS yet that might work? 
> 
> I just updated it yesterday.  Update to 0.3 and things should work: 
> 
> dstumbler wi0 -o 
> 
> -sc 
> 
> -- 
> Sean Chittenden
 


 --
Ryan "leadZERO" Sommers
Gamer's Impact President
ryans at gamersimpact.com
ICQ: 1019590
AIM/MSN: leadZERO 

 -= http://www.gamersimpact.com =- 


More information about the freebsd-current mailing list