escalation stage 2 [was:RE: Big and ugly bug in 5.1-release]

Harald Schmalzbauer h at
Tue Jul 15 19:21:27 PDT 2003

Julian Elischer wrote:
> On Wed, 16 Jul 2003, Harald Schmalzbauer wrote:
> > Now after resetting the machine which was hung by "sysinstall" it claims
> > that ad4 (one of two mirrored 30GB 2.5" disks" was absent (see
> dmesg below)
> mirrored by what?

By ata. It is reognized as ar0 after setting it up in the controller's BIOS
(in contrast to the DC-133 which needs to be configured with atacontrol for
beeing recognized by the kernel with ar0)

> > Now the controller warns me that one drive is bad (which in fact is
> > definatley not) and allows me to select "continue boot"
> Th controller is not controlled by FreeBSD.
> If the controller says the drive is bad when you are in the BIOS,
> Then it is bad.

It's not. Like I said I did dozends of test before and whenever it claimd
the harddrive to be bad a simple channel change (ad4 got ad6 and vice versa)
solved this "error" message. But I also lost data, so this is no option
rigth now!!!

> > That's what I do and after kernel probing the machine reboots with the
> > folowing error (well, this takes some time to typewrite it from
> my monchrome
> > screen):
> If you have another computer nearby, connect the serial cables together
> (with a null-modem cable) and put
> console="comconsole"
> in file
> /boot/loader.conf
> then your output will occur on the serial port .
> then you will not have to type in the information.

That'd work if boot2 would detect the serial console or with -h or the "dual
flag". I had some experience with FreeBSD kernel and serial console the last
fiew weeks (on a Soekris box) but not on a headless system.

You see, I'm really in trouble

Thank you,


> >
> > Fatal trap 12: page fault while in kernel mode
> > fault virtual address = 0x10
> > fault code=			supervisor read, page not present
> > instruction pinter=	0x8:0xc014a0a6
> > stack pointer=		0x10:0xcce65bd8
> > frame pointer=		0x10:0xcce65c58
> > code	segment		= base 0x0, limit 0xfffff type 0x1b
> > 				= DPL 0, pres 1, def32 1, gran 1
> > processor eflags		= interrupt enabled, resume, IOPL=0
> > current process		= 4(g_down)
> > trap number			= 12
> > panic: page fault
> >
> > Then it reboots!
> >
> > Now please give me a hint what to do. This is my brand new
> fileserver which
> > collected all improtant data from the last decade and since
> it's brand new I
> > didn't manage any backup.
> > When testing the hardware (unplugging one drive while the machine was
> > running) I had the same error but I thought that would never
> happen under
> > normal circumstances.
> >
> > If sysinstall breakes a RAID1 server 5.1-RELEASE should be immediately
> > replaced by a corrected version!!!!!
> FreeBSD 5.1 is a 'testing' release. you are warned not to use it for
> production. If you do use it you must know how to upgrade your system
> from there to correct bugs that may occur.
> The message above comes from 'geom' which is the disk
> handling code. It has had some work done recently so it may be that the
> author (phk at can help you, but it seens to me that you may
> really have a disk problem.

More information about the freebsd-current mailing list