headless cluster install

c0ldbyte c0ldbyte at myrealbox.com
Fri Apr 1 17:00:53 PST 2005

Hash: SHA1

On Fri, 1 Apr 2005, Understudy wrote:

> Hi,
> I am attempting to do a headless install with FreeBSD 5.3. The handbook is 
> out of date on this. %.3 has a boot.flp and two kern.flp . The handbook asks 
> you to do a echo "/boot/loader -h" > boot.config to the kern.flp but that is 
> not the first floppy in 5.3 boot.flp is. So I tried it with boot.flp and it 
> did not work. My question is very specific.
> How can I configure the boot.flp to successfully do a headless install?
> It is not desirable to remove the hard drive, and place it another machine, 
> and try to copy it that way.
> Sincerely,
> Brendhan

Located at: 
Section: 1.5.6 Tips for Serial Console Users.

It states the following:


     1.5.6 Tips for Serial Console Users

    If you'd like to install FreeBSD on a machine using just a serial
    port (e.g. you don't have or wish to use a VGA card), please
    follow these steps:

     1. Connect some sort of ANSI (vt100) compatible terminal or
        terminal emulation program to the COM1 port of the PC you are
        installing FreeBSD onto.

     2. Unplug the keyboard (yes, that's correct!) and then try to
        boot from floppy or the installation CDROM, depending on the
        type of installation media you have, with the keyboard

     3. If you don't get any output on your serial console, plug the
        keyboard in again. If you are booting from the CDROM, proceed
        to step 5 as soon as you hear the beep.

     4. If booting from floppies, when access to the disk stops,
        insert the first of the kernX.flp disks and press Enter. When
        access to this disk finishes, insert the next kernX.flp disk
        and press Enter, and repeat until all kernX.flp disks have
        been inserted. When disk activity finishes, reinsert the
        boot.flp floppy disk and press Enter.

     5. Once a beep is heard, hit the number 6, then enter

  boot -h

        and you should now definitely be seeing everything on the
        serial port. If that still doesn't work, check your serial
        cabling as well as the settings on your terminal emulation
        program or actual terminal device. It should be set for 9600
        baud, 8 bits, no parity.


Does that solve your problem or give you a hint of what to do ?

Best regards,

Version: GnuPG v1.4.0 (FreeBSD)
Comment: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xF7DF979F
Comment: Fingerprint = D1DC 0AA4 1C4E EAD4 24EB  7E77 B261 50BA F7DF 979F


More information about the freebsd-cluster mailing list