apache24 broken after change from lua to lua51?

Peter Olsson pol at leissner.se
Sat Jun 21 11:47:32 UTC 2014

Thanks, this seems to work. At least the compilation of
apache24 works now. But I can't install devel/luabind
or net/luasocket, because they get different errors when
I change them from USES=lua:51 to USES=lua:52.
luabind gets a compile error, and luasocket seems to have
a staging problem.

So the patch I really need is to be able to keep using
lua51 combined with apache24. I'm not sure if this is a
question for lua or apache?

(I'm including lx at FreeBSD.org in Cc, as maintainer of


Peter Olsson

On Fri, Jun 20, 2014 at 10:52:06PM +0200, olli hauer wrote:
> On 2014-06-20 17:49, Peter Olsson wrote:
> > Hello!
> > 
> > After the change from lua to lua51, compilation of
> > apache24 fails with this:
> > 
> > checking for sqrt in -lm... yes
> > checking for lua.h in /usr/local/include/lua5.1... no
> > checking for lua.h in /usr/local/include/lua51... yes
> > checking for luaL_newstate in -llua... no
> > configure: WARNING: *** Lua 5.1 library not found.
> > configure: error: Lua 5.1 library is required
> > 
> > I have this installed:
> > lua51-5.1.5_7                      =   up-to-date with index
> > 
> > I even tried deinstallating lua and let apache24 drag it in,
> > but that didn't help either.
> > 
> > I'm using 9.2-RELEASE-p7 with pkgng, and installing with portmaster.
> The httpd-2.4.x configure script self announce only support for lua5.1 (hard coded).
> Anyway with the patch below the port builds even with lua5.2.
> All messages containing lua will report lua5.1 even with lua5.2 because of the hard wired version.
> After the build a check with the command should display the correct lua version.
> $ ldd work/stage/usr/local/libexec/apache24/mod_lua*
> Please test the following patch and report back if mod_lua is working.
> http://people.freebsd.org/~ohauer/diffs/apache24_lua.diff
> -- 
> Regards,
> olli

More information about the freebsd-apache mailing list